Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #21935
    Marco Baum
    Participant

    Hi Team,

    We are currently testing your plugin and unfortunately we have a problem for which we have not found a solution. If a customer buys a product and then goes to “My Courses” in their profile and clicks on “View”, they unfortunately cannot access the course. An error message appears as shown below.

    Warning:
    Warning: Cannot modify header information – headers already sent by (output started at /app/wp-content/themes/blocksy/header.php:12) in /app/wp-includes/pluggable.php on line 1435

    Warning: Cannot modify header information – headers already sent by (output started at /app/wp-content/themes/blocksy/header.php:12) in /app/wp-includes/pluggable.php on line 1438

    I hope u can help us.

    Greetings

    #21940
    dualcube
    Keymaster

    Hi @Marco Baum, I’m sorry to hear that you’ve encountered this issue.

    Based on the error message, it appears to be originating from your theme. Could you please reach out to your theme author and inform them that you are using a plugin which has created its own endpoint under the WooCommerce My Account page, and this error is occurring on that page?

    Once you have their response, please share it with us so we can assist you further.

    p.s. We have been diligently working over the past two weeks on upgrading MooWoodle Pro and MooWoodle. These upgrades ensure compatibility with the latest versions of WordPress and Moodle, with better UI.

    If you would like to test this new version, you are welcome to use it on your end. We aim to officially release this beta version by next week. You can create a staging site and install the plugin from here – https://drive.google.com/file/d/1TvQJKkEYWwwFjxboY-L7US4Rd7ZevZfW/view?usp=drive_link

    #21959
    Marco Baum
    Participant

    Hello, unfortunately we have this problem with every theme. Even with the standard WordPress themes, this message appears. So it must be the plugin, right?

    For example on WP Theme “Twenty Twenty-Four”:
    Warning: Cannot modify header information – headers already sent by (output started at /app/wp-includes/template-canvas.php:13) in /app/wp-includes/pluggable.php on line 1435

    Warning: Cannot modify header information – headers already sent by (output started at /app/wp-includes/template-canvas.php:13) in /app/wp-includes/pluggable.php on line 1438

    And i tested 5 different Themes.

    #21960
    dualcube
    Keymaster

    Hi @Marco Baum, as you are facing this issue on your end, so can you please share a temporary admin access of your site and ftp. So, we can check and provide you with a solution.

    While sharing the access, don’t forget to mark the reply as private.

    #22070
    Marco Baum
    Participant

    @dualcube The problem is that our site is set to private because we work via VPN. Unfortunately, that’s how we work in the company. Is there another solution? Can we somehow send the WordPress/database by email or something similar??

    #22071
    Purnendu Dash
    Keymaster

    Hi Marco, Not to worry.

    I am happy to inform you that we have been diligently working over the past two weeks on upgrading MooWoodle. These upgrades ensure compatibility with the latest versions of WordPress and Moodle, with better UI and code.

    I kindly suggest testing this new version on your staging site to verify if the issue has been resolved: https://drive.google.com/file/d/1OAwAK1Hgronv7dPUeIAiG6WOLEWFjrn2/view?usp=drive_link

    Please do keep us posted.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.